Subject: Entity locks in asterixdb

From: abdullah alamoudi <[email-masked]>
Date: Sun, 3 Sep 2017 10:38:39 -0700

Hi All,
I have created a wiki entry for entity level locks in asterixdb at https://cwiki.apache.org/confluence/display/ASTERIXDB/Entity+locks+in+AsterixDB <https://cwiki.apache.org/confluence/display/ASTERIXDB/Entity+locks+in+AsterixDB> 
It is pretty primitive at this stage but with your contribution, it can be improved quite a bit.
The goal of this entry is to act as a reference to our locking for developers, testers, and users as well. We would like to use it as the basis as we're adding unit tests to locking within different cursors as we're adding unit tests to those.

Special mention to @Taewoo to take a look :)

Cheers,
~Abdullah.

---

From: Taewoo Kim <[email-masked]>
Date: Sun, 03 Sep 2017 18:19:15 +0000

Sure. I will take a look after my break. Thanks.

On Sun, Sep 3, 2017 at 19:38 abdullah alamoudi <[email-masked]> wrote:

> Hi All,
> I have created a wiki entry for entity level locks in asterixdb at
> https://cwiki.apache.org/confluence/display/ASTERIXDB/Entity+locks+in+AsterixDB
> <
> https://cwiki.apache.org/confluence/display/ASTERIXDB/Entity+locks+in+AsterixDB
> >
> The goal of this entry is to act as a reference to our locking for
> developers, testers, and users as well. We would like to use it as the
> basis as we're adding unit tests to locking within different cursors as
> we're adding unit tests to those.
>