Subject: inserting into an autogenerated key dataset from a query result

From: Steven Jacobs <[email-masked]>
Date: Tue, 19 Sep 2017 10:08:01 -0700

Hi all,
I'm seeing a strange issue when inserting into a dataset with an
autogenerated key the result of a query. I was wondering if anyone has had
success with such a case. I have a simple example below which fails on
master (The full JIRA issue is here:
https://issues.apache.org/jira/browse/ASTERIXDB-2101)

drop dataverse channels if exists;
create dataverse channels;
use channels;
create type result as {
  id:uuid
};
create type subscriptionType as {
  subscriptionId:uuid,
  param0:int
};
create dataset roomRecordsResults(result)
primary key id autogenerated;
create dataset roomRecordsSubscriptions(subscriptionType)
primary key subscriptionId autogenerated;
use channels;
insert into channels.roomRecordsResults (
  select sub.subscriptionId
  from channels.roomRecordsSubscriptions sub
);

---

From: Mike Carey <[email-masked]>
Date: Tue, 19 Sep 2017 10:49:06 -0700

Note that this works on the release from a couple of weeks ago, so this 
is a regression that got missed by our tests (surprise!) it seems.

---

From: Steven Jacobs <[email-masked]>
Date: Tue, 19 Sep 2017 11:20:47 -0700

Apologies, this appears to be only happening on my local copy of master.
I've cleaned and rebuilt several times and still can't get it to resolve
locally, but it seems to be my problem and not the code base.
Steven

On Tue, Sep 19, 2017 at 10:49 AM, Mike Carey <[email-masked]> wrote:

> Note that this works on the release from a couple of weeks ago, so this is
> a regression that got missed by our tests (surprise!) it seems.
>
>
>